Try to install ContentBlocks 1.8.15-pl on MODX 3.0.0.-alpha3

Hi,

i try to install CB on a fresh MODX 3.0.0-alpha3 installation, but the install process interrupt with “Could not install package with signature: contentblocks-1.8.15-pl”.

I tried it locally (MAMP) and on our live server, but it fails every time. I check the transport package but I can’t find any vehicle file with the missing GUID.

I tried to install CB on latest MODX2 but it fails also. But some weeks ago I installed it locally and on public server without any problems?

I deleted the package, and download it again, same result.

Do you have any idea how I can solve the problem?

Here ist the instalation logfile:

Thanks for the report, I’ll fix the installation on MODX 3 in v1.8.16.

Can you provide the log for the failed MODX2 installation?

Hi Mark,

thanks for the fast reply. Here is a screenshot of the revolution log.

Hm, can you try removing the package and downloading it fresh?

I did it before, but i done it again ^^

My way:

  1. I delete the packages inside the Package Manager
  2. I purge all Old Packages inside the Package Manager
  3. I delete every CB related DB entries like system_settings, menus and namespaces, because the uninstall routine dont run
  4. I check on server side that all packages where be deleted
  5. Download and install again, but the same error.

In that case that seems to suggest it can’t do the actual decoding. It gets the decryption key successfully, but somehow that doesn’t work.

I’ve not seen this sort of thing recently, but it may be related to OpenSSL in your PHP configuration. Perhaps that’s something you can look at to make sure that’s up to date?

Ok, I have change the OpenSLL version from 1.0.2n 7 Dec 2017 to 1.1.1b 26 Feb 2019

But i get the same result.

I tried to install other of your MODX 3 ready extras like Redactor 3, ClientConfig or Scheduler – no problem.

On a fresh install, i also tried with my private modmore account instead of our company account, but i got the same result.

Also on a fresh 3.0.0-alpha2 (not alpha3) i had no luck …

Hi Mark,

I tried some tests again.

To eliminate local / public server configuration errors, I have run all test inside a Docker environment based on the official modx docker repository.

MODX 2.7.0 / PHP 7.1 => no problem
MODX 2.7.3 / PHP 7.3 => no problem
MODX 3.0.0-alpha2 / PHP 7.3 => same error (Download Log: https://www.dropbox.com/s/z4k7f9yxlyvze1o/output-2020-04-27_modx_3.txt?dl=0)

After these tests, I have try locally (MAMP) test again.

MODX 2.7.3 / PHP 7.3 => no problem :slight_smile:
MODX 3.0.0-alpha2 / PHP 7.3 => same error like before

Now my working solution to use CB with MODX 3 is:

  1. Install MODX 2.7.3
  2. Install CB
  3. Update to MODX 3.0.0-alpha2

Now I hope, that an update of the next version of CB will be run without errors.

Like I said,

I haven’t released v1.8.16 yet.

The issue resulting in message “Could not retrieve the decryption key.” is an issue in the installation code that makes it only compatible with MODX 2.x, not related to PHP versions at all.