*SOLVED* Paypal Gateway not working in sandbox mode

Hey there,

I am trying to implement the PayPal Payment Gateway into my simplecart installation. When redirected to PayPal I am prompted with the following error msg

This transaction is invalid. Please return to the recipient’s website to complete your transaction using their regular checkout flow.

When using CURL for a test call it is working without any issues.

Any ideas how to debug this issue? My sandbox API credentials seem to be valid and active.

Thanks in advance

Did some further investigation.

return curl_error($ch);

Output: [2016-01-25 14:53:48] (ERROR @ /index.php) [SimpleCart] PayPal: error:14077410:SSL routines:SSL23_GET_SERVER_HELLO:sslv3 alert handshake failure
[2016-01-25 14:53:48] (ERROR @ /index.php) Order is NOT verified

Recording to this post on stackoverflow PayPal made some adjustments to there SSL certificates. I assume that these changes need to be implemented into the PayPal Gateway as well…

I’m getting this issue as well, but don’t immediately see what we’d need to change in the gateway. It almost sounds like an issue with the SSL root certificates not being up to date, however that is typically only an issue on PHP 5.5/5.6 and I’m also seeing it on an older version.

Will need to investigate further…

I am running PHP 5.3.x on CentOS 5. I assume it might be related to PayPal changing the sandbox from SHA-1 to SHA-256. This means CURL needs to use TLS 1.2. However this is only supported with OpenSSL 1.0.1 and CURL 7.34.0.

I am running CURL 7.15.5 with OpenSSL 0.9.8b…

Is there anything new regarding this issue?

Upgrading your server should do the trick, as confirmed by https://forums.modx.com/thread/99380/minishop2-latest#dis-post-537544 (and the post following that).

It might be a good idea for us to build in a check in the gateway during installation to make sure the server meets these new requirements as at some point in the future this change will also affect their live endpoints.

I moved the SimpleCart installation to our new CentOS 7 server environment running:

OpenSSL 1.0.1e-fips 11 Feb 2013
curl 7.47.0 (x86_64-redhat-linux-gnu)

And it is still not working. So the problem might be related to the gateway plugin.

Any ideas?


Solved, after also installing openssl-devel package.