MODX 3 failed to add provider

Hello, I am running MODX3.x on MODXCloud. I created my api keys, but am getting an error message for the URL.

This Provider could not be verified, and therefore cannot be used as a MODX Provider. Please check the service URL and try again.

It works from bookmarklet but not manually entering the content.

When copy-pasting, it’s very common for an extra space to be copied along at the start or end of any of the values (url, username, or API key). Those are incredibly hard to spot and likely the case here too.

Yeah, I checked that on the URL before I posted to the forum. Still not working, but I stopped trying as the bookmarklet worked.

I am going to explore ContentBlocks in a proof of concept Dev cloud on MODXCloud. I think it will be the right tool to implement our university’s atomized template.


It could’ve also been in the username or api key, but the bookmarklet does always work. :slight_smile: If you want to debug connection issues further, please email, but I assume you’re sorted now.

If you’re using atomic design, ContentBlocks should indeed fit with that quite well. If you have any questions about ContentBlocks or how you may approach a certain type of template, be sure to ask :slight_smile: