Manager Blank after upgrade MG to 1.16

Hi I have an issue after upgrading MoreGallery from 1.15.1 to 1.16 in MODx 3.0.3. After the Upgrade the Manager is blank.

Any errors in the browser console that may indicate missing files or such?

Please also check the MODX and PHP error logs.

No, just blank, no errors in Console. It’s a shared Hosting at IONOS, I only found the access log, but no PHP log. I found the MODx log in the cache folder. There are some errors related to a MediaSource

[2023-10-28 16:42:25] (ERROR @ /homepages/24/d284534311/htdocs/www3/httpdocs/core/vendor/xpdo/xpdo/src/xPDO/xPDO.php : 786) modMediaSource::getSelectColumns() is not a valid static method.
[2023-10-28 17:07:39] (ERROR @ /homepages/24/d284534311/htdocs/www3/httpdocs/core/src/Revolution/Sources/modFileMediaSource.php : 57) Konnte die Medienquelle "Stellenangebote" nicht initialisieren! Unable to create a directory at . mkdir(): Invalid path
[2023-10-28 17:11:16] (ERROR @ /homepages/24/d284534311/htdocs/www3/httpdocs/core/src/Revolution/Sources/modFileMediaSource.php : 57) Could not initialize "Stellenangebote" Media Source! Unable to create a directory at . mkdir(): Invalid path

But I’m not sure if this causes the complete blank Manager.

I’m sorry. There is an error 500 in the console.

For what request is the 500 error? Anything in the response for that request if you look in the network tab?

No, the request is directly from the manager. I also cannot see the login page. The complete manager is blank. This is strange. I’ll recover the backup and check if there are any hidden issues.

Could the reason be a renamed “Manager” folder? I renamed it for security reasons and used it that way for years. However, after importing the backups, I renamed it back to “Manager” and now it works. At least with MoreGallery version 1.15.1 and Modx 3.0.3.

It could be if there was a misconfigured path somewhere, that you fixed in the process of renaming it back.

However, without an error message, that’s just throwing darts in the dark as to why it was failing and what the actual root cause was.

For now it works. I’ll test it later on an own server with more log information.