Gitify - composer dependencys w php 7.1

When trying to install gitify composer dependencys I get the following issue:

    /user/home/Gitify $ composer install
Deprecation warning: Your package name modmore/Gitify is invalid, it should not contain uppercase characters. We suggest using modmore/gitify instead. Make sure you fix this as Composer 2.0 will error.
Deprecation warning: require.kbjr/Git.php is invalid, it should not contain uppercase characters. Please use kbjr/git.php instead. Make sure you fix this as Composer 2.0 will error.
Loading composer repositories with package information
Installing dependencies (including require-dev) from lock file
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - Installation request for phpunit/php-code-coverage 7.0.3 -> satisfiable by phpunit/php-code-coverage[7.0.3].
    - phpunit/php-code-coverage 7.0.3 requires php ^7.2 -> your PHP version (7.1.29) does not satisfy that requirement.
  Problem 2
    - Installation request for phpunit/phpunit 8.1.6 -> satisfiable by phpunit/phpunit[8.1.6].
    - phpunit/phpunit 8.1.6 requires php ^7.2 -> your PHP version (7.1.29) does not satisfy that requirement.
  Problem 3
    - Installation request for sebastian/global-state 3.0.0 -> satisfiable by sebastian/global-state[3.0.0].
    - sebastian/global-state 3.0.0 requires php ^7.2 -> your PHP version (7.1.29) does not satisfy that requirement.

Are php 7.1 not supported anymore, or is this unexpected?

Use composer install --no-dev (as mentioned in the readme).

The development dependencies need some work to make sure it will install properly.

Thanks, that worked.

I always follow the instructions here: https://docs.modmore.com/en/Open_Source/Gitify/Installation/index.html

I’ll make a PR for adding the --no-dev to those.

Already beat you to that. https://github.com/modmore/docs/commit/dee3e94f6736a1beb2f8ccb3c95c37120667e3de :stuck_out_tongue:

1 Like