Date (month) is displayed in english, even if locale is "de_DE"

Agenda 1.1.0-b10:
I have set &locale=`de_DE` in [[AgendaList]], locale-system-setting is also set to de_DE, but still the date (month) is only displayed in English …

Is the locale de_DE available? Maybe you have only de_DE.utf8 available. Please check this.

How do I check this?

The page is located on a shared host at Ionos/1&1 (definitly not my choice!) and at the moment, I have no access to the server settings. PHP is 7.2.30.

I tried de_DE.utf8 in the settings and in the snippet, but nothing has changed.

locale -a when SSH’ed into the server is the simplest way I know to check installed locales.

system("locale -a") in a snippet gave me an exhaustive list of locales: de_DE as well as de_DE.utf8 are included.

And echo setlocale(LC_CTYPE, 0); showed that de_DE is set. So I guess this is not the source of the error.

Strange, it uses the Carbon locales internally. And it works fine here. I will check this in the next days.

In between you could use the agenda.locale context/system setting or the locale context/system setting. It should fallback to those settings.

Could you tell me, which placeholder is filled with the wrong locale?

It’s the placeholder for the date-range in both [[AgendaList]] and [[AgendaDetail]]: [[+range]]. All the lexicon fields get the right language. But for the range I get e.g.
25. May 2020, 10:00 – 17:00 Uhr – note that »Uhr« is correct!

Sorry for the late reply, I have to setup a mail notify for this board.

I will check this issue local.

It will be fixed with Agenda 1.1-rc1

1 Like