Automating my Gitify Workflow

I currently try to improve my Gitify workflow by automating things. Inspiration came from this SlideShare form @mhamstra from 2015.

Setting up Gitify Watch worked well, but now I am stucked with my first problems.

Setup directory

It looks like I need a setup directory in my repository because Gitify is looking for a file in there. Here is the error message: Could not open input file: setup/index.php

How am I supposed to handle the setup directory in my repository as it will be removed each time I run the setup. Also I don’t want it to be available in my production environment.

Menu Items disappear in Manager

After I did some content shiftings from development to production (i only have these while testing the process) I noticed that some menu items were missing. How can I prevent this?

⇒ More questions will follow, but I have to get the train now :wink:

The setup is only needed during a modx:install, which should be putting that in place for you when it downloads the last available version. So you shouldn’t need to keep it in VCS or keep it around another way.

Those menu items… gremlins? :stuck_out_tongue: I’m not sure. If you’re including modMenu in your gitify data, perhaps the rank isn’t specifically set and builds are causing those to get mixed up. If you’re not including them, the order can be different due to the order in which extras are installed.

I updated the error message in OP. What I did this time:

  • Clone my Modx Project
  • Try to run Gitify modx:install
  • Got the error message: Could not open input file: setup/index.php

All steps as described in the Guide.

So Gitify did download a fresh copy of Modx 2.6.2 but it did not use the files … don’t get why it is downloading modx but not using it. Is Gitify checking for something that could prevent it from using the fresh files (and which should therefore not be part of my git repository/Gitify project)?

I guess the Gitify documentation could need a What to include in your Gitify project section :smile:

Moh … just had to install unzip … But now it’s noted :smile:

Consider this part of the thread as solved :wink:

Thanks again!